Reports of a NEU Blackboard Outage on Campus
Incident Report for Northeastern University - ITS
Resolved
This issue has been resolved.
Posted about 1 year ago. Jun 20, 2017 - 15:37 EDT
Investigating
ITS is receiving reports of users having difficulties connecting to NEU Blackboard (blackboard.neu.edu). We are investigating this issue and hope to have it resolved soon.

We will provide updates as more information becomes available.
Posted about 1 year ago. Jun 20, 2017 - 14:15 EDT