Chrome 7 experiencing difficulties accessing myNEU
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 27, 2017 - 15:21 EST
Identified
Users Affected: Chrome on Windows 7, OS X
Website Affected: myneu.neu.edu
Error: “You have either timed-out due to inactivity or have logged out from a previous session". You must go directly to https://myneu.neu.edu.

Solution:
1) Close all myNEU tabs/windows
2) Clear all Cookies, Cache, and other Browsing data making sure to select 'From the Beginning of Time'.
3) Immediately after, Access myNEU using this link: https://myneu.neu.edu **Make sure to include the 's' in 'https'
Posted 9 months ago. Jan 31, 2017 - 10:37 EST