Errors populating throughout Blackboard (blackboard.neu.edu)
Resolved
This incident has been resolved.
Posted Sep 20, 2016 - 15:46 EDT
Investigating
ITS is investigating a rise in errors in our Blackboard instance. We are working with Blackboard to fix this issue. Please email help@northeastern.edu, or call 617.373.4357 to report any issues that you may be having.

Thanks,
Northeastern ITS
Posted Sep 20, 2016 - 09:37 EDT