In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 28, 2024 - 18:30 EDT
Update - Maintenance to the Family Hub has been postponed. Maintenance to the Student Hub will begin as scheduled at 6 p.m. ET today. Community members will not have access to the Student Hub during the 90-minute maintenance.

A brief outage to me.northeastern.edu is also expected. The Employee Hub and Family Hub will be unreachable from this site during the brief site outage.

Mar 28, 2024 18:30-20:00 EDT
Scheduled - Maintenance to the Family Hub and Student Hub will begin at 6 p.m. ET on Thursday, March 28. Community members will not have access to the Family Hub or Student Hub during the 90-minute maintenance.

A brief outage to me.northeastern.edu is also expected. The Employee Hub will be unreachable from this site during the site brief outage.

Services will resume by close of the 90-minute maintenance window

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.

Mar 28, 2024 18:30-20:00 EDT

About This Site

Known technology issues or outages that impact the Northeastern community are shared on this status page. To report an issue please call 617.373.HELP (4357). Remember - if you see something, say something!

Account Access and Security Under Maintenance
Alumni Accounts Operational
Directory Services Operational
Duo Security Core Authentication Service ? Operational
Duo Security Phone Call Delivery ? Operational
Duo Security Push Delivery ? Operational
Duo Security SMS Message Delivery ? Operational
Faculty / Staff Accounts Operational
Family Hub Under Maintenance
Family / Other Accounts Operational
Single Sign On (SSO) ? Operational
Sponsored Accounts Operational
Student Accounts Operational
Administration and Business Under Maintenance
Banner - Advancement Operational
Banner - Finance Operational
Banner - Human Resources Operational
Banner - Self-Service Operational
Banner - Student Operational
CashNet ? Operational
Course Registration and Management Operational
Employee Hub ? Under Maintenance
ePAWs (Grant Management) Operational
myNortheastern Portals ? Operational
Salesforce ? Operational
ServiceNow ? Operational
ServiceNow Mobile App Operational
Sunapsis (myOGS) ? Operational
Communication and Collaboration Operational
3CLogic Automated Call Distribution ? Operational
Exchange (Email) ? Operational
five9 Automated Call Distribution ? Operational
G Suite ? Operational
LISTSERV ? Operational
Microsoft Excel ? Operational
Microsoft Teams ? Operational
Microsoft Word ? Operational
Microsoft SharePoint ? Operational
Computing and Software Operational
Jamf ? Operational
Microsoft InTune ? Operational
Network Printing Operational
PaperCut (General-use printing) Operational
Windows Software Deployment Systems (SCCM) ? Operational
Department Storage (Q:) ? Operational
Enterprise Systems ? Operational
Network Infrastructure Operational
Data Center Network Connectivity Operational
Efficient IP Operational
Load Balancing Operational
NAS Storage Operational
Network Power Operational
NUNET (Wired Network / Physical) ? Operational
NUwave (Wireless Network / Access Points) ? Operational
VPN ? Operational
Other Operational
Public Cloud Services Operational
Amazon Web Services (AWS) Operational
Azure ? Operational
Secure Compute Operational
Research Computing Operational
Discovery Cluster Compute ? Operational
Discovery Cluster Storage ? Operational
Open onDemand ? Operational
Schrodinger / Maestro ? Operational
Spaces at Northeastern Operational
Robin Dashboard Operational
Robin Mobile Operational
Robin Public Website Operational
Robin Room Displays Operational
Robin Status Boards Operational
Student Services Under Maintenance
Husky Card (CBORD / Husky Card Activity) ? Operational
I Am Here ? Operational
Student Billing (Outsystems Link) Operational
Student Hub ? Under Maintenance
Teaching and Learning Operational
Canvas ? Operational
Panopto ? Operational
Zoom Meeting Telephony Services Operational
Zoom Web Client Operational
Zoom Web Portal Operational
Zoom Zoom Chat Operational
Zoom Zoom Meetings Operational
Zoom Zoom Video Webinars Operational
Other Operational
Web Solutions Operational
Sites at Northeastern Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024
Resolved - The incident has been resolved and all Northeastern sites hosted on WP Engine are loading properly.
Mar 28, 09:53 EDT
Identified - IT teams have identified the misconfiguration issue and are working diligently with WP Engine to fully resolve the impacted sites.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.

Mar 28, 09:50 EDT
Update - We are continuing to investigate this issue.
Mar 28, 09:11 EDT
Update - We are continuing to investigate this issue.
Mar 28, 09:07 EDT
Investigating - IT teams are investigating reports of WordPress sites hosted on WP Engine redirecting to the D'Amore-McKim School of Business site, causing the affected sites to be inaccessible. This issue impacts various Northeastern websites.

IT Teams has engaged with WP Engine and internal partners to investigate the issue.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.

Mar 28, 09:06 EDT
Mar 27, 2024
Completed - The scheduled maintenance has been completed.
Mar 27, 21:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 27, 20:00 EDT
Scheduled - Maintenance to redirect https://artcollection.mills.edu/ to collection.mcam.northeastern.edu will begin at 5 p.m. PT on Wednesday, March 27. Community members should expect a service outage during the one-hour maintenance window. 
 
Visitors to artcollection.mills.edu will be automatically redirected to the new domain following the maintenance. Customers are encouraged to update bookmarks to the new domain: collection.mcam.northeastern.edu.
 
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.

Mar 25, 15:04 EDT
Completed - The scheduled maintenance has been completed.
Mar 27, 06:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 27, 05:30 EDT
Scheduled - Maintenance to upgrade the wireless network for the Roux Institute in Portland will begin at 5:30 a.m. ET on Wednesday, March 27. Brief service interruptions of up to five-minutes are expected during the maintenance window.

This maintenance is part of ongoing network upgrades that will increase capacities across the global network.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.

Mar 26, 13:29 EDT
Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024
Completed - The scheduled maintenance has been completed.
Mar 18, 07:39 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 17:00 EDT
Scheduled - Maintenance to upgrade to Cognos will begin at 5 p.m. ET today, Friday, March 15 and end at 8 a.m. ET on Monday, March 18.

Cognos services will be unavailable during the entire maintenance. Active sessions will be terminated and community members will need to log back in to Cognos following close of the maintenance window.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.

Mar 15, 13:38 EDT
Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024
Completed - The scheduled maintenance has been completed.
Mar 15, 19:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 16:30 EDT
Update - We will be undergoing scheduled maintenance during this time.
Mar 14, 10:43 EDT
Scheduled - Maintenance to upgrade certificates for Oakland legacy Kyocera Copiers will begin at 1:30 p.m. PT on Friday, March 15. Kyocera Copiers will be unavailable for use during the three-hour maintenance window.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.

Mar 14, 10:04 EDT
Mar 14, 2024
Completed - The scheduled maintenance has been completed.
Mar 14, 19:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 14, 18:00 EDT
Scheduled - Maintenance to the Employee Hub will begin at 6 p.m. ET today, Thursday, March 14. Community members will not have access to the Employee Hub during this maintenance. A brief outage to me.northeastern.edu is also expected with Student Hub unreachable from this site. Services will resume by close of the 90-minute maintenance window

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.

Mar 14, 09:36 EDT