Merit increase phishing attempt
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 10, 2017 - 17:45 EST
Investigating
There was a recent phishing email sent out that requested your log in information due to a merit increase in salary. If you have entered your credentials, please call the Help Desk at 617.373.4357, in order to change your log in information. Remember, Northeastern will never request your log in information.

Thanks,
Northeastern ITS
Posted 8 months ago. Mar 10, 2017 - 12:00 EST