Degraded Service | MyNortheastern Employee Portal
Resolved
As of June 1, 2023, all services and links on the myNortheastern employee portal will be retired and found exclusively on the Employee Hub. Until then, both websites will be available.

Access the Hub from any device by going to me.northeastern.edu and signing in with employee credentials. To learn more about the Hub, visit about.me.northeastern.edu/employee-hub for more information and FAQs.

For other questions or issues using the Hub, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted May 09, 2023 - 15:09 EDT
Identified
Employees may now access the new Employee Hub to find all the services and links from the myNortheastern portal on the Resources section of the Hub. The Employee Hub is available via web browser. Access the Hub from any device by going to me.northeastern.edu and signing in with employee credentials. Employees are encouraged to start transitioning to the Hub for their day-to-day needs.

For any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Mar 16, 2023 - 12:14 EDT
Update
The issue has been identified and IT teams continue to engage with the vendor.

For any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Mar 16, 2023 - 12:13 EDT
Update
IT teams continue to engage with the vendor to identify a solution. It is recommended that anyone visiting the MyNortheastern employee portal do so using a desktop computer rather than a mobile device.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Feb 28, 2023 - 11:29 EST
Update
IT teams continue to engage with the vendor to identify a solution for this issue.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Feb 07, 2023 - 13:51 EST
Update
IT teams continue to engage with the vendor to identify a solution. Updates will be shared as they become available.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Feb 01, 2023 - 09:25 EST
Update
IT teams continue to engage with the vendor to identify a solution. It is recommended that anyone visiting MyNortheastern employee portal do so using a desktop computer rather than a mobile device until the issue is resolved. Updates will be shared as they become available.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jan 24, 2023 - 10:53 EST
Update
IT teams continue to engage with the vendor to identify a solution. Updates will be shared as they become available.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jan 18, 2023 - 09:24 EST
Update
IT teams continue to engage with the vendor to identify a solution. Updates will be shared as they become available.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jan 11, 2023 - 08:56 EST
Update
IT teams continue to engage with the vendor to identify a solution. Community members may continue to experience degraded services. It is recommended that anyone visiting MyNortheastern employee portal do so using a desktop computer rather than a mobile device until the issue is resolved. Updates will be shared as they become available.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jan 09, 2023 - 09:58 EST
Investigating
The MyNortheastern employee portal is currently experiencing degraded services. ITS staff is engaged with the vendor to escalate the issue and identify a solution. It is recommended that anyone visiting MyNortheastern employee portal do so using a desktop computer rather than a mobile device until the issue is resolved. Community members may notice degraded services in the Events window, general menu functionality, Favorites, and History, among others. Updates will be shared as they become available.

For additional questions and assistance, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal (services.northeastern.edu/tech).
Posted Jan 06, 2023 - 15:17 EST
This incident affected: Administration and Business (myNortheastern Portals).