Microsoft 365 Access Interruption
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 08:34 EDT
Monitoring
Microsoft has implemented a fix to correct issues impacting user access to select 365 services- results are continued to be monitored.
Posted Apr 01, 2021 - 19:23 EDT
Investigating
Microsoft is currently investigating an issue impacting users access to select Microsoft 365 services, including Teams . We will provide additional information as soon as possible.
Posted Apr 01, 2021 - 17:57 EDT