MyNortheastern Unplanned Downtime
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved. Thank you for your patience while we worked to get the portal back up and running.
Posted 14 days ago. Nov 30, 2018 - 13:34 EST
Monitoring
ITS has brought the myNortheastern portal back up online and we are monitoring it. We will continue to provide updates.
Posted 14 days ago. Nov 30, 2018 - 13:14 EST
Identified
ITS has identified the issue with the portal as the same that affected the portal during Thursday's downtime. We are working to resolve the issue. We will continue to provide updates.
Posted 14 days ago. Nov 30, 2018 - 12:48 EST
Investigating
The MyNortheastern portal is currently unavailable. ITS is investigating the issue and will communicate updates.
Posted 14 days ago. Nov 30, 2018 - 12:43 EST
This incident affected: myNortheastern & Services.