TurnItIn Outage
Incident Report for Northeastern University - ITS
Resolved
TurnitIn outage has been restored to service. Please contact the Help Desk with additional issues or questions.
Posted 3 months ago. Aug 13, 2018 - 12:05 EDT
Identified
ITS is aware that the TurnItIn service is currently unavailable. Our vendor (Turnitin) has been made aware of the issue and we are working with them to restore access ASAP. Thank you for your patience.
Posted 3 months ago. Aug 13, 2018 - 09:08 EDT
This incident affected: Blackboard Services.