Undergraduate student applicants receiving unexpected account claim emails
Resolved
IT Services has resolved this issue.

For additional questions and assistance, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal (services.northeastern.edu/tech).
Posted Feb 03, 2023 - 16:58 EST
Monitoring
IT teams worked with the vendor over the weekend to address the delays and errors with student account claims. The system is running smoothly now and students who received an account claim link can now try to activate their Northeastern account.

Some errors may still occur for those who previously tried claiming accounts. If issues linger, please contact the IT Service Desk 617.373.HELP [4357], help@northeastern.edu, or service.northeastern/tech. Have your full name and NUID ready. If following up about an existing ticket, reference the ticket number to expedite support.
Posted Jan 30, 2023 - 08:40 EST
Identified
IT Services is seeing processing delays and timeouts with student account claims. As a result, those who have claimed accounts or do attempt to claim accounts may experience timeouts before receiving their username or password. If this is the case, please contact the IT Service Desk at 617.373.HELP [4357], help@northeastern.edu, or service.northeastern/tech. Please reference full name and NUID when possible.

If delays or other errors occur, please try again in a few hours. If they persist, please contact the IT Service Desk at 617.373.HELP [4357], help@northeastern.edu, or service.northeastern/tech. If calling about an existing ticket, please have a ticket number ready to reference.

IT teams are working with the vendor to address these processing errors and will continue to share updates on StatusPage.
Posted Jan 28, 2023 - 14:20 EST
Investigating
IT Services is investigating reports of undergraduate student applicants who have received email notification to claim a Northeastern account even though they have not received an application decision yet. Applicants who do claim are unable to log in.

Updates will be posted to StatusPage when more is known.
Posted Jan 28, 2023 - 10:11 EST
This incident affected: Account Access and Security (Student Accounts).