Unable to Reset Passwords
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 09:59 EDT
Monitoring
IT Services has worked with the vendor to put in a fix to resolve the issue. Students, alumni, and family/other accounts holders can now update passwords, and request and claim accounts. Users who change their password may need to wait approximately 5 minutes after the change before being able to successfully log in using the new password.
Posted Oct 01, 2021 - 17:35 EDT
Update
Northeastern IT Services is continuing to work with Saviynt engineering resources to implement a resolution to restore access to password resets and account claim control for Student, Family and Parent/Other account holders.
Posted Oct 01, 2021 - 16:37 EDT
Identified
Users are continuing to experience password timeouts when attempting to reset passwords. The university’s third-party vendor, Saviynt, is reviewing the issue and working on a resolution.
Posted Oct 01, 2021 - 15:31 EDT
Update
Users are experiencing password timeouts when attempting to reset their passwords. This issue has been escalated as a high-priority ticket with the university's third-party vendor, Saviynt.
Posted Oct 01, 2021 - 14:49 EDT
Investigating
IT Services is investigating reports of students, alumni, and family/other account holders unable to reset their Northeastern passwords.
Posted Oct 01, 2021 - 14:41 EDT
This incident affected: Account Access and Security (Alumni Accounts, Family / Other Accounts, Student Accounts).