myNortheastern Portal Access Interruption
Resolved
Access to the myNortheaster portal has been restored.
Posted Apr 16, 2021 - 10:35 EDT
Investigating
Members of IT Services are currently investigating reports of users being unable to access the myNortheastern portal.
Posted Apr 16, 2021 - 08:42 EDT
This incident affected: Administration and Business (myNortheastern Portals).