Microsoft Users Unable to Connect to Network Printers
Resolved
This incident has been resolved. If issues accessing network printing continues, please contact the Service Desk for support by calling 617.373.HELP [4357] or emailing help@northeastern.edu
Posted Oct 13, 2021 - 10:30 EDT
Monitoring
Northeastern IT Services in partnership with Microsoft engineer resources have implemented a solution to restore Microsoft User's access to Network Print services and are continuing to monitor the service. To regain access, Microsoft users must run all necessary updates.

View helpful tips on running Windows 10 updates by visiting https://service.northeastern.edu/tech?id=kb_article&sys_id=e4e76ee187ceb41094dfda0d3fbb35d8

The Service Desk is also available to help answer questions regarding Windows 10 updates by contacting 617.373.HELP [4357], help@northeastern.edu, or via live chat on the Tech Service Portal.
Posted Oct 07, 2021 - 17:02 EDT
Update
IT Services is continuing to investigate reports of Windows users being unable to connect to network printers.
Posted Oct 05, 2021 - 15:51 EDT
Investigating
Northeastern IT Services is currently investigating reports of Windows users not able to connect to network printers.
Posted Oct 05, 2021 - 15:11 EDT
This incident affected: Computing and Software (Network Printing).