NUnet Network Down on Dedham Campus
Incident Report for Northeastern University - ITS
Resolved
The network has been restored to Northeastern in Dedham. A power issue caused the outage, and ITS was able to reset it. Thank you for your patience.
Posted 6 days ago. Dec 08, 2018 - 23:43 EST
Investigating
We have reports that there is no internet or network connectivity at the Northeastern location in Dedham. We have opened up a ticket with Comcast and are waiting for status update. We will continue to share updates.
Posted 7 days ago. Dec 07, 2018 - 15:50 EST
This incident affected: Network.