PaperCut Outage | Student Printing

Monitoring

Papercut printing services are back to normal and IT teams are monitoring.
Posted Nov 26, 2025 - 11:09 EST

Investigating

IT teams are investigating issues with PaperCut student printing. Printers are unable to release jobs on the embedded screen. A workaround is to use the QR code on the printer to release jobs. Updates will be share to IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Nov 26, 2025 - 09:55 EST
This incident affects: Computing and Software (PaperCut (General-use printing)).