Unplanned Blackboard SAAS Upgrade
Incident Report for Northeastern University - ITS
Resolved
A compulsory Blackboard update was preventing access to the Grade Center for faculty and My Grades for students. We have confirmed that the Grade Center and My Grades features have returned to normal functionality. We apologize for the inconvenience and will be working with Blackboard to minimize impacts during their compulsory upgrade periods in the future.

Please let us know if you continue to encounter issues with the Grade Center or My Grades feature.
Posted 8 months ago. Jan 31, 2019 - 20:09 EST
Identified
Due to a SAAS upgrade on the Blackboard platform, some users may lose access to the Grade Center and myGrades. It should be available again at approximately 8 p.m.
Posted 8 months ago. Jan 31, 2019 - 19:23 EST
This incident affected: Blackboard Services.