Intermittent log in issues on myNortheastern
Resolved
This incident has been resolved. If any issues persist, or to report another issue, please contact the IT Service Desk at 617.373.HELP[4357].
Posted Feb 07, 2020 - 16:25 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 07, 2020 - 16:22 EST
Monitoring
A fix has been implemented to resolve the "Screen name" prompt. Users may have to clear their internet browser's cache before attempting to log in again. If issues persist even after clearing cache, please contact the IT Service Desk at 617.373.HELP [4357].
Posted Feb 06, 2020 - 08:54 EST
Update
We are continuing to investigate this issue.
Posted Feb 06, 2020 - 08:18 EST
Investigating
Some users are reporting a “Screen name" prompt when trying to access myNortheastern portal. This issue is being investigated.
Posted Feb 06, 2020 - 08:18 EST
This incident affected: Administration and Business (myNortheastern Portals).