MyNortheastern Login Issue Reported
Incident Report for Northeastern University - ITS
Resolved
ITS has confirmed that access to the portal has been restored. Please contact the Service Desk (617.373.4357 [xHELP] or help@northeastern.edu) if you experience any further issues.
Posted 5 months ago. Nov 20, 2018 - 11:34 EST
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Nov 20, 2018 - 10:57 EST
Monitoring
The issue was identified on one of the servers and a fix has been put into place. The affected server will be up shortly. Users that are still receiving an error or unavailable message should clear their browser cookies and try logging in to a new portal session.
Posted 5 months ago. Nov 20, 2018 - 10:57 EST
Investigating
Users are reporting an issue while logging into MyNortheastern. The SSO page is loading something different and will not login. ITS is investigating this issue.
Posted 5 months ago. Nov 20, 2018 - 10:48 EST
This incident affected: myNortheastern & Services.