Issues Accessing Services with MyNortheastern Credentials
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 05, 2019 - 17:16 EDT
Monitoring
The login issues that users were reporting appear to be resolved, but the impacted services are being monitored.
Posted 13 days ago. Jun 05, 2019 - 14:15 EDT
Investigating
We are currently investigating this issue.
Posted 13 days ago. Jun 05, 2019 - 14:10 EDT
This incident affected: myNortheastern & Services.