Turnitin Service Issues
Incident Report for Northeastern University - ITS
Resolved
Turnitin indicates that the issue has been resolved. ITS will be monitoring Turnitin's system status at http://turnitin.status.io/pages/59a83c00d031972d05000063. If you experience any further issues with Turnitin performance, please contact the ITS Service Desk at 617.373.4357 or help@northeastern.edu. Thank you for your patience.
Posted 7 days ago. Dec 07, 2018 - 13:21 EST
Investigating
Multiple users are confirming problems with viewing and grading Turnitin assignments.

Instructors may have difficulty loading Turnitin student papers to grade them.

Students can submit new papers, but may not be able to load previously submitted papers to review their instructor's feedback.

Errors that might display: "Loading", "Login Error", "Your Session Has Expired"

NOTE: this does not affect Blackboard assignments or other assignment tools, only Turnitin.
Posted 8 days ago. Dec 07, 2018 - 12:04 EST
This incident affected: Other.