Student Hub Spring Quarter CPS Students Preferences Impact
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 14:58 EDT
Identified
This morning, the Student Hub team discovered a data issue preventing new Spring Quarter CPS students from submitting seat preferences for classes beginning the week of April 12. The team is working to correct this issue to enable submission of preferences for classes scheduled the week of April 19.

For the week of April 12, preferences will default to the “in-person” option. Students will receive assignments on Sunday, and may make changes to preferences at that time.

If you need any additional technology assistance, the IT Service Desk is available 24/7 at 617.373.HELP [4357], help@northeastern.edu, and the Tech Service Portal.
Posted Apr 07, 2021 - 17:46 EDT
This incident affected: Student Services (Student Hub).