NUflex Classroom 'Tech Help' Button Disconnected
Resolved
The Tech Help button feature has been disabled within NUflex classrooms. Email classroomITsupport@northeastern.edu if in need of immediate technology assistance during a class session in these rooms. Always include the building name and classroom number in the subject of the email.

For all other technology requests, including questions about this issue, contact the IT Service Desk at 617.373.HELP [4357] or through service.northeastern.edu/tech.
Posted May 04, 2023 - 14:26 EDT
Monitoring
IT teams have identified and are working to address the ongoing issue affecting the Tech Help button feature of the touch screen in NUflex classrooms. The Tech Help button feature has been temporarily disabled within NUflex classrooms. Email classroomITsupport@northeastern.edu if in need of immediate technology assistance during a class session in these rooms. Always include the building name and classroom number in the subject of the email.

For all other technology requests, including questions about this issue, contact the IT Service Desk at 617.373.HELP [4357] or through service.northeastern.edu/tech.
Posted Feb 02, 2023 - 16:01 EST
Update
IT teams continue to engage with the vendor to identify a solution. Updates will be shared as they become available.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Feb 01, 2023 - 10:38 EST
Investigating
IT Services is investigating reports that requests for assistance using the 'Tech Help' button in NUflex classrooms are not being received. Teams from Northeastern and vendors are looking into this to identify the issue.

In the meantime, instructors requiring IT support while teaching in NUflex classrooms should email classroomITsupport@northeastern.edu to dispatch a technician. Include the building name and room number in the email subject line.

For all other technology requests, including questions about this issue, contact the IT Service Desk at 617.373.HELP [4357] or through service.northeastern.edu/tech.
Posted Jan 20, 2023 - 18:26 EST
This incident affected: Teaching and Learning (Other).