Northeastern Websites Degraded Performance
Resolved
This incident has been closed.
Posted Jan 27, 2022 - 16:06 EST
Monitoring
The website issues and slow loading times appear to have returned to normal. The university’s Web Solutions Team continues to monitor the situation. The issue was identified as a service outage affecting one of the university’s CDN (content delivery network) service providers.

Further updates will be shared here as they become available.

To report any additional errors or issues accessing university web properties, please contact the IT Service Desk.
Posted Jan 14, 2022 - 19:23 EST
Investigating
IT Services is currently investigating reports of Northeastern associated websites headers and footers not loading correctly, and causing delays in pages loading.
Posted Jan 14, 2022 - 15:59 EST
This incident affected: Other.