Errors with signing into Microsoft services
Resolved
If any issues persist, please contact the IT Service Desk at 617.373.HELP [4357] or help@northeastern.edu.
Posted Jan 14, 2021 - 17:48 EST
Monitoring
The login issues have been fixed, and users should no longer be experiencing the error when accessing university sites.
Posted Jan 14, 2021 - 17:26 EST
Investigating
Some users are experiencing errors when logging into certain Northeastern websites with their myNortheastern login credentials. Reports indicate that this is happening for Microsoft services, including the Student Hub and the COVID-19 Test Scheduler. The issue is being investigated.
Posted Jan 14, 2021 - 17:10 EST
This incident affected: Student Services (Student Hub).