Multiple Systems | Log In Errors

Monitoring

Banner service has resumed. IT teams are still engaged and monitoring systems.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Nov 26, 2025 - 12:09 EST

Update

Banner is still unavailable and showing server errors, but IT teams are focused on getting service back up as quickly as possible. Other systems may have intermittent slowness and errors. Statuspage will continue to share regular updates.
Posted Nov 26, 2025 - 11:30 EST

Update

IT teams continue to investigate intermittent errors, slowness, and other issues affecting multiple services. Reports show there may be impacts to various systems, including Banner, Papercut printing, e-PAWS, Degreeworks, and Tableau. Statuspage will continue to share regular updates.
Posted Nov 26, 2025 - 10:46 EST

Investigating

IT teams are investigating reports of single sign on (SSO) errors for faculty, staff, and students. Community members are getting log in errors on some applications, including Banner. Updates will be shared to IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Nov 26, 2025 - 10:15 EST
This incident affects: Computing and Software (PaperCut (General-use printing)), Enterprise Systems, and Account Access and Security (Single Sign On (SSO)).