The student printing system (Pharos) is currently experiencing system outages
Incident Report for Northeastern University - ITS
Resolved
All student printing services (Pharos) have been restored and should be fully functional. If you continue to encounter any issues, please contact the Help Desk at 617.373.4357 or help@northeastern.edu.
Posted 7 months ago. Apr 03, 2017 - 13:24 EDT
Investigating
ITS is aware, and is working on getting it back ASAP. Please call the Help Desk at 617.373.4357 with any issues, or email help@northeastern.edu
Posted 7 months ago. Apr 03, 2017 - 10:30 EDT