The affected local ISP is stable and this issue is considered fully resolved.
Posted May 29, 2025 - 19:27 EDT
Monitoring
Service has returned, with confirmed reports of successful connections to both wired and wireless networks. IT teams identified the issue as an outage with one of the local internet service providers and configured settings to move to a different ISP. Teams will be continuing to monitor.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 23, 2025 - 10:00 EDT
Update
IT teams are continuing to troubleshoot. Some wired connections have been successful, and staff on site are assisting with active, on-site class sessions. All internet, including wireless, continues to be unreliable. Next update will be posted by 10:30 a.m. ET, or sooner.
Posted May 23, 2025 - 09:32 EDT
Update
IT teams are continuing to troubleshoot and are engaging with the internet service provider (ISP) in Toronto. Wired and wireless services continue to be unavailable or unreliable. Next update will be posted by 9:30 a.m. ET, or sooner.
Posted May 23, 2025 - 08:47 EDT
Update
IT teams are coordinating with on-site staff to troubleshoot the issue. Updates will continue to be shared to the IT Statuspage.
Posted May 23, 2025 - 07:25 EDT
Investigating
IT teams are investigating an outage to the network power on the Toronto Campus. All internet and network connections went down overnight. Updates will be shared to the IT Statuspage as they become available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.