Increased Errors l Canvas

Resolved

Instructure, the vendor, has restored service to Canvas.

To report any additional issues, please contact the IT Service Desk 24/7 at 617.373.HELP (4357), help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 04, 2026 - 20:15 EDT

Monitoring

Canvas is investigating errors and increased slowness, which are impacting the Northeastern community. Northeastern teams are monitoring the Canvas status at https://status.instructure.com/incidents/7y1x3qd9sj51.
Posted May 04, 2026 - 20:03 EDT
This incident affected: Teaching and Learning (Canvas).