Northeastern.edu Access Interruption
Resolved
This incident has been resolved and access to Northeastern.edu and other associated sites has been restored.
Posted Jul 22, 2021 - 13:14 EDT
Investigating
Members of IT Services are investigating reports of users being unable to access Northeastern.edu.
Posted Jul 22, 2021 - 12:21 EDT
This incident affected: Other.