Degraded Service | Workday

Resolved

This incident has been resolved, Workday functions are restored.
Posted Mar 22, 2026 - 14:31 EDT

Identified

IT teams are aware of a Workday system degradation currently being addressed by Workday.

During this time, some users may experience performance issues, including delays or failures when completing actions such as uploading documents or running processes in Workday. Scheduled reports and integrations may also be impacted.

Workday has identified the issue and is actively implementing a fix. Updates will be shared as more information becomes available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 22, 2026 - 13:36 EDT
This incident affected: Administration and Business (Workday).