Five9 ACD is currently down for all of Boston campus.
Resolved
Service has been restored to Five9 Automated Call Distribution and users should be able to access all related resources. If any issues persist, please contact the IT Service Desk at 617.373.HELP [4357] or at help@northeastern.edu.
Posted Jan 15, 2022 - 16:12 EST
Investigating
Northeastern IT Services are currently investigating reports that Five9 Automated Call Distribution numbers are not functional for the Boston campus.
Posted Jan 15, 2022 - 15:59 EST