Websphere Outage l Global

Monitoring

IT teams have restored service and members of the university community once again have access to the impacted services. Teams continue to monitor.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 04, 2026 - 15:32 EDT

Update

IT teams continue to investigate and work to restore services as quickly as possible.
Posted Aug 04, 2026 - 11:30 EDT

Investigating

IT teams are investigating an outage impacting WebSphere, which is affecting several services, including NUPay payment processing. Members of the university community may experience issues accessing impacted services or completing payment transactions at this time.

Technical teams are actively investigating the issue and working to restore service as quickly as possible. Additional updates will be provided as more information becomes available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 04, 2026 - 10:36 EDT
This incident affects: Enterprise Systems.