Shibboleth Single Sign On (SSO) is down

Resolved

This service is stable and continues to work as expected.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 02, 2025 - 09:30 EDT

Monitoring

Employee access to Banner applications has been restored. All applications that use Shibboleth SSO are now fully restored. IT teams will continue to monitor to ensure no new issues arise.
Posted Jul 01, 2025 - 14:05 EDT

Update

Another update will be shared here at 2:30 p.m. ET.
Posted Jul 01, 2025 - 13:46 EDT

Identified

IT teams have resorted access to applications that use Shibboleth SSO. Banner student including course registration, schedules, and grades is fully restored.

Employees may still experience issues with Banner applications. The team is actively implementing a fix for these issues.

Another update will be shared here at 2:30 p.m. ET.
Posted Jul 01, 2025 - 13:45 EDT

Update

IT teams are making solid progress as they continue to work on this issue. A more substantial update will be shared here at 1:30 p.m. ET.
Posted Jul 01, 2025 - 13:10 EDT

Update

IT teams continue to investigate. Another update will be shared here at 1 p.m. ET.
Posted Jul 01, 2025 - 12:30 EDT

Update

IT teams are still investigating. Another update will be shared here at 12:30 p.m. ET.
Posted Jul 01, 2025 - 12:00 EDT

Update

IT teams continue to investigate the cause of this outage. Another update will be shared here at 12 p.m. ET.
Posted Jul 01, 2025 - 11:30 EDT

Investigating

IT teams are investigating Shibboleth single sign on (SSO) not functioning. As a result, access to Banner course registration, Family Hub, NUWorks and other services using Shibboleth for sign on is impacted. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 01, 2025 - 11:04 EDT
This incident affected: Administration and Business (Banner - Advancement, Banner - Finance, Banner - Human Resources, Banner - Self-Service, Banner - Student) and Account Access and Security (Single Sign On (SSO)).