Billing System Change | Toronto and Vancouver
Resolved
Student Financial Services Canada is excited to announce that the new billing and payment system is now LIVE.

To access your latest billing statements and/or make payments moving forward, visit the Student Hub then select the Billing tab.

Historical billing and payment information from prior to March 5, 2024 can still be found on the Financial Force portal.

For any billing questions visit the Student Financial Services portal.

For other questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 05, 2024 - 16:06 EST
Update
The new billing and payment portal for Canadian campuses is expected to be available to process student bill payments by end of business today, Mar. 6. Once the new system is fully implemented, an update will be provided here to the IT Statuspage.
Posted Mar 05, 2024 - 15:28 EST
Monitoring
Launch of the new billing and payment system for students at Northeastern's Canadian locations has been postponed to perform additional tests. Statuspage will be updated when the new system is enabled and available for use.

After the new billing and payment system is enabled, students should access their latest billing statements and/or make payments by visiting the Student Hub then selecting the Billing tab.

Historical billing and payment information from prior to March 5, 2024 can be found on the Financial Force portal.

For any billing questions visit the Student Financial Services portal.

For other questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 04, 2024 - 17:32 EST
This incident affected: Student Services (Student Hub) and Other.