Course Registration Links Unavailable l NU Accelerate Program
Resolved
The fix addressed the issue and students in the NU Accelerate program are able to register for classes directly through Banner Self-Service.

If any issues persist, please reach out to the IT Service Desk at 617.373.HELP or through https://service.northeastern.edu/tech.
Posted Mar 13, 2024 - 16:31 EDT
Update
The fix has been completed and testing is underway to confirm whether the impacted students are now able to register for courses.
Posted Mar 13, 2024 - 11:54 EDT
Identified
A fix to address the issue has been identified and is being implemented. It's expected to be applied within the next hour. Further updates will be shared on Statuspage as soon as they're available.
Posted Mar 13, 2024 - 10:40 EDT
Investigating
IT teams are investigating reports that course registration links are not available for students in the NU Accelerate Program through the expected paths. The course registration link is not available in either the Student Hub or Banner. ITS is working with business stakeholders and the Registrar on this issue.
Posted Mar 13, 2024 - 09:45 EDT
This incident affected: Administration and Business (Course Registration and Management).