Network Disruptions l Global

Resolved

All service has been restored. To report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 06, 2026 - 14:54 EDT

Monitoring

IT teams put in a fix and impacted services appear to be returning to normal. Teams continue to monitor.
Posted Aug 06, 2026 - 10:31 EDT

Investigating

IT teams are currently investigating reports of disruptions to certain wired and wireless connections on the Boston, Nahant, and Oakland campuses. Additional updates will be provided as more information becomes available.

To report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 06, 2026 - 10:10 EDT
This incident affected: Network Infrastructure (NUnet (Wired Network / Physical), NUwave (Wireless Network / Access Points)).