Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 29, 2025 - 12:00 EDT
Scheduled
Maintenance to upgrade single sign on (SSO) for the London Handshake application will take place from 5-6:30 p.m. GT on Wednesday, October 29. Community members should expect a service outage of up to an hour and a half during the maintenance window.
After the upgrade, the site path access will remain the same, but the login process will require Northeastern credentials to access the site.
Visit 1login.its.northeastern.edu to learn more about this initiative to simplify the university's SSO experience.
For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Oct 23, 2025 - 11:33 EDT
This scheduled maintenance affected: Account Access and Security (Single Sign On (SSO)).