To report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 03, 2025 - 08:32 EDT
Update
The Workday freeze is taking longer than expected. Workday access is now expected to resume on Thursday, July 3 at 5 a.m. PT, 8 a.m. ET, 1 p.m. GT.
Posted Jul 02, 2025 - 18:02 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2025 - 00:00 EDT
Scheduled
Workday will be unavailable to all university community members during the launch of Workday Finance. The service outage will begin on Sunday, June 29. Access will resume at 3 p.m. PT, 6 p.m. ET, and 11 p.m. GT on Wednesday, July 2.
To report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 27, 2025 - 08:26 EDT
This scheduled maintenance affected: Administration and Business (Workday).