Network Outage l Dodge Hall, Boston Campus

Resolved

IT teams have confirmed that the network is fully operational in Dodge.
Posted Mar 07, 2026 - 07:57 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2026 - 19:51 EST

Identified

A power issue affected the first-floor network closet, contributing to the service disruption.
Posted Mar 06, 2026 - 19:48 EST

Investigating

IT teams are investigating reports of a network outage in Dodge Hall on Boston campus affecting wired and wireless internet. Staff are en route to site. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 06, 2026 - 18:32 EST
This incident affected: Network Infrastructure (Network Power, NUnet (Wired Network / Physical), NUwave (Wireless Network / Access Points)).