Network Outage | Hastings Hall

Resolved

IT teams have implemented a fix and the network power is restored.
Posted Jul 24, 2026 - 10:09 EDT

Identified

IT teams have investigated reports of a network outage in Hastings Hall and are working to implement a fix. This network outage is impacting the wired and wireless network.

Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 24, 2026 - 10:01 EDT
This incident affected: Network Infrastructure (Network Power, NUnet (Wired Network / Physical), NUwave (Wireless Network / Access Points)).