Reports of a NUwave outage
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 11, 2017 - 16:43 EDT
Investigating
ITS is receiving reports of users being unable to connect to NUwave. [If applicable, add the location]. We are currently investigating. If you are having a problem connecting, please email as much information as possible to help@northeastern.edu.
Posted 2 months ago. Sep 11, 2017 - 13:42 EDT