Service Outage | Claude

Resolved

Anthropic has restored Claude. IT teams tested and confirmed that community members can again access Claude using their Northeastern accounts.
Posted May 27, 2025 - 21:01 EDT

Investigating

IT Services teams are investigating an outage to Claude by Anthropic. Updates will be shared to IT Statuspage as they become available from Anthropic.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 27, 2025 - 19:21 EDT
This incident affected: Enterprise Systems.