Spaces at Northeastern powered by Robin l Loading Errors

Resolved

Robin has resolved this issue. Spaces at Northeastern is back online.
Posted Aug 27, 2025 - 16:22 EDT

Investigating

The Robin platform that powers Spaces at Northeastern bookings is experiencing issues loading. This issue is affecting all Robin users. The vendor is sharing updates on its Statuspage at https://status.robinpowered.com/.
Posted Aug 27, 2025 - 08:01 EDT
This incident affected: Spaces at Northeastern (Robin Dashboard, Robin Mobile).