All new accounts are now accessible. Password resets and all other account services are working as expected.
For further assistance, or for any questions, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 31, 2025 - 16:07 EDT
Update
Password changes are now functioning as expected. A fix has been put into place for the impacted new accounts and should fully resolve over the weekend. Access for new accounts should be restored by the start of business Monday morning, or sooner. IT teams will be monitoring.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 30, 2025 - 15:53 EDT
Monitoring
Account functionality appears to be restored. Teams are confirming now and will continue to monitor to ensure ongoing stability.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 30, 2025 - 14:53 EDT
Update
IT teams are continuing to troubleshoot. The university is engaged with the third-party, Saviynt, and working on identifying the issue and the fix. Next update will be posted to Statuspage by 3 p.m. ET.
Posted May 30, 2025 - 14:27 EDT
Investigating
IT teams are investigating reports of account issues across all account types. Saviynt isn't pushing any updates to Active Directory. This means new accounts claimed can't sign in to university services, such as email and Teams. It also means other changes, such as password resets and changes, aren't reflecting. Updates will be shared to the IT Statuspage as they become available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 30, 2025 - 14:09 EDT
This incident affected: Account Access and Security (Alumni Accounts, Faculty / Staff Accounts, Sponsored Accounts, Student Accounts).