Exchange Online Access
Resolved
Microsoft reports this issue has been resolved. Users should have full access to services restored at this time.
Posted Jul 20, 2021 - 08:43 EDT
Identified
IT Services have identified an issue preventing some users from being able to sign into Exchange Online from any connection methods. This issue is specific to Exchange Online and hybrid Exchange users hosted on infrastructure in North and West Europe, as well as East United States whose mailboxes are unable to be detected correctly by the AutoDetect service. A resolution is being pursued.
Posted Jul 15, 2021 - 10:33 EDT
Investigating
Members of IT Services are currently investigating reports of users being unable to access Microsoft Exchange services online.
Posted Jul 15, 2021 - 09:12 EDT
This incident affected: Communication and Collaboration (Exchange (Email)).