Purchasing Errors l Jaggaer Portal

Monitoring

Jaggaer has applied the fix. Some persistent slowness remains and is still being investigated, but systems appear to be stabilizing. Northeastern will continue to monitor and share an update when one is available.
Posted Aug 19, 2026 - 18:50 EDT

Identified

Jaggaer has identified the root cause and will perform a fix at 4 p.m. ET today to address the issue and improve stability.

Next update will be shared once an update is available.
Posted Aug 19, 2026 - 16:07 EDT

Investigating

Jaggaer is reporting intermittent errors affecting IntelliBuy, Northeastern's procurement system. This is a vendor-side issue, and Jaggaer is actively investigating the cause.

Users may experience issues completing purchasing transactions or accessing certain IntelliBuy functions. ITS is monitoring the situation and will provide updates as more information becomes available.
Posted Aug 19, 2026 - 15:36 EDT
This incident affects: Administration and Business (IntelliBUY).