Wireless Network Outage | Vancouver

Resolved

The network has been fully restored for the Vancouver campus.
Posted Oct 31, 2025 - 12:41 EDT

Identified

At this time, degraded wireless service is only affecting the 14th floor of West Georgia on the Vancouver campus. IT teams have identified the issue and are working on a fix.
Posted Oct 31, 2025 - 11:14 EDT

Investigating

The wireless network is experiencing degraded service on the Vancouver campus. IT teams are investigating. Updates will be shared as they become available.

For any questions or support, please contact the IT Service Desk at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Oct 31, 2025 - 09:27 EDT
This incident affected: Network Infrastructure (NUwave (Wireless Network / Access Points)).