Service Outage l Churchill Hall

Postmortem

A full network outage on the third floor of Churchill Hall disrupted both wired and wireless services, preventing users from accessing network resources on that floor.

Our team identified the incident, activated the incident response process, fully restored services, and returned network connectivity to normal.

We appreciate your patience and understanding during this disruption.

Posted Mar 06, 2026 - 12:08 EST

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 19:13 EST

Investigating

IT teams are investigating reports of a service outage impacting the third floor of Churchill Hall. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 05, 2026 - 16:55 EST