Issues logging into university services
Incident Report for Northeastern University - ITS
Resolved
Login issues have been resolved. If you were previously affected by this issue while trying to access university services, please try again. Thank you for your patience.
Posted about 1 month ago. Aug 07, 2019 - 14:23 EDT
Investigating
There is currently an issue affecting logging into university services with myNortheastern credentials. This issue is being investigated and updates will be shared as they are available.
Posted about 1 month ago. Aug 07, 2019 - 13:30 EDT
This incident affected: Blackboard Services, Enterprise Systems, and myNortheastern & Services.