Service Outage | Solstice Wireless Display

Monitoring

Solstice wireless display pods still aren't functioning in some classrooms. As a workaround, please connect to the display using an HDMI cable.

For immediate in-classroom support, please visit the help page on the Classroom Dashboard.
Posted Mar 26, 2025 - 14:06 EDT

Update

IT teams are still working with the vendor to resolve the licensing issue. For immediate in-classroom support, please visit the help page on the Classroom Dashboard.
Posted Mar 13, 2025 - 12:35 EDT

Identified

Solstice wireless display pods aren't functioning in some classrooms due to a licensing error. ITS teams are working with the vendor to resolve the issue. Service is expected to be restored tomorrow, Wednesday, March 12.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 11, 2025 - 10:57 EDT
This incident affects: Teaching and Learning (Other).